using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"sometext(?!(?:[\/.-]|\s*)\d{1,2}\b)";
string input = @"sometext
sometext
sometext dsf 2131
sometext-1234
sometext 12
sometext 3
sometext2
sometext-1";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}