import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "sometext(?!(?:[\\/.-]|\\s*)\\d{1,2}\\b)";
final String string = "sometext\n"
+ "sometext \n"
+ "sometext dsf 2131\n"
+ "sometext-1234\n\n"
+ "sometext 12\n"
+ "sometext 3\n"
+ "sometext2\n"
+ "sometext-1";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}