const regex = /sometext(?!(?:[\/.-]|\s*)\d{1,2}\b)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('sometext(?!(?:[\\\/.-]|\\s*)\\d{1,2}\\b)', 'gm')
const str = `sometext
sometext
sometext dsf 2131
sometext-1234
sometext 12
sometext 3
sometext2
sometext-1`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}