$re = '/sometext(?!(?:[\/.-]|\s*)\d{1,2}\b)/m';
$str = 'sometext
sometext
sometext dsf 2131
sometext-1234
sometext 12
sometext 3
sometext2
sometext-1';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);