# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(define[\s\S]*{)([\s\S\n\r]+?)(var\s+)([$\w_]+)(\s+)(.*)([,;])([\s\S\n\r]+?)(\w)/\1\2var _ = require('underscore'),\8 \4\5\6\7\8\9/g;t' <<< "define(function(require, exports, module) {
var UIKit = require('uikit/uikit');
var ExtendUtil = require('helpers/extend.util');
var ConfirmModalView = UIKit.Modal2.extend({
define([
'underscore',
'marionette',
'../libs/spf.helper',
'../templates',
'uikit/injector',
'uikit/component.collection.view',
'uikit/grid',
'uikit/table',
'uikit/text',
'uikit/button'
], function(_, Mn,
// data stuff
SPFHelper,
Templates,
// view stuff
InjectorView, ComponentCollectionView, GridView, TableView, TextView, ButtonView) {"