const regex = /(define[\s\S]*{)([\s\S\n\r]+?)(var\s+)([$\w_]+)(\s+)(.*)([,;])([\s\S\n\r]+?)(\w)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(define[\\s\\S]*{)([\\s\\S\\n\\r]+?)(var\\s+)([$\\w_]+)(\\s+)(.*)([,;])([\\s\\S\\n\\r]+?)(\\w)', 'g')
const str = `define(function(require, exports, module) {
var UIKit = require('uikit/uikit');
var ExtendUtil = require('helpers/extend.util');
var ConfirmModalView = UIKit.Modal2.extend({
define([
'underscore',
'marionette',
'../libs/spf.helper',
'../templates',
'uikit/injector',
'uikit/component.collection.view',
'uikit/grid',
'uikit/table',
'uikit/text',
'uikit/button'
], function(_, Mn,
// data stuff
SPFHelper,
Templates,
// view stuff
InjectorView, ComponentCollectionView, GridView, TableView, TextView, ButtonView) {`;
const subst = `\1\2var _ = require('underscore'),\8 \4\5\6\7\8\9`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);