// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(define[\s\S]*{)([\s\S\n\r]+?)(var\s+)([$\w_]+)(\s+)(.*)([,;])([\s\S\n\r]+?)(\w)").unwrap();
let string = "define(function(require, exports, module) {
var UIKit = require('uikit/uikit');
var ExtendUtil = require('helpers/extend.util');
var ConfirmModalView = UIKit.Modal2.extend({
define([
'underscore',
'marionette',
'../libs/spf.helper',
'../templates',
'uikit/injector',
'uikit/component.collection.view',
'uikit/grid',
'uikit/table',
'uikit/text',
'uikit/button'
], function(_, Mn,
// data stuff
SPFHelper,
Templates,
// view stuff
InjectorView, ComponentCollectionView, GridView, TableView, TextView, ButtonView) {";
let substitution = "\\1\\2var _ = require('underscore'),\\8 \\4\\5\\6\\7\\8\\9";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}