# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(define[\s\S]*{)([\s\S\n\r]+?)(var\s+)([$\w_]+)(\s+)(.*)([,;])([\s\S\n\r]+?)(\w)"
test_str = ("define(function(require, exports, module) {\n"
" var UIKit = require('uikit/uikit');\n"
" var ExtendUtil = require('helpers/extend.util');\n\n\n"
" var ConfirmModalView = UIKit.Modal2.extend({\n\n\n"
"define([\n"
" 'underscore',\n"
" 'marionette',\n\n"
" '../libs/spf.helper',\n\n"
" '../templates',\n\n"
" 'uikit/injector',\n"
" 'uikit/component.collection.view',\n"
" 'uikit/grid',\n"
" 'uikit/table',\n"
" 'uikit/text',\n"
" 'uikit/button'\n"
" ], function(_, Mn,\n"
" // data stuff\n"
" SPFHelper,\n\n"
" Templates,\n"
" // view stuff\n"
" InjectorView, ComponentCollectionView, GridView, TableView, TextView, ButtonView) {")
subst = "\\1\\2var _ = require('underscore'),\\8 \\4\\5\\6\\7\\8\\9"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.