#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?<!\S)Bob[\s._-]1(?![^\s._-])"
Local $sString = "Hello, I'm Bob 1 --> Should capture Bob 1" & @CRLF & _
"Hello, I'm Bob 11 --> Should capture nothing (Bob 1 is not at the end or followed by a separator)" & @CRLF & _
"Hey, it's Bob-1 over there --> Should capture Bob-1" & @CRLF & _
"Hey, it's Bob - 1 over there --> Should capture nothing (Bob should be followed only by one separator not 3 like here)" & @CRLF & _
"Bob.1 --> Should capture Bob.1" & @CRLF & _
"Bob_1 rules! --> Should capture Bob_1"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")