use strict;
my $str = 'Hello, I\'m Bob 1 --> Should capture Bob 1
Hello, I\'m Bob 11 --> Should capture nothing (Bob 1 is not at the end or followed by a separator)
Hey, it\'s Bob-1 over there --> Should capture Bob-1
Hey, it\'s Bob - 1 over there --> Should capture nothing (Bob should be followed only by one separator not 3 like here)
Bob.1 --> Should capture Bob.1
Bob_1 rules! --> Should capture Bob_1';
my $regex = qr/(?<!\S)Bob[\s._-]1(?![^\s._-])/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}