# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?<!\S)Bob[\s._-]1(?![^\s._-])"
test_str = ("Hello, I'm Bob 1 --> Should capture Bob 1\n"
"Hello, I'm Bob 11 --> Should capture nothing (Bob 1 is not at the end or followed by a separator)\n"
"Hey, it's Bob-1 over there --> Should capture Bob-1\n"
"Hey, it's Bob - 1 over there --> Should capture nothing (Bob should be followed only by one separator not 3 like here)\n"
"Bob.1 --> Should capture Bob.1\n"
"Bob_1 rules! --> Should capture Bob_1")
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.