import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:[^\"'\\n]*(?:\"(?:[^\"\\n]|\"\")*\"))*[^']*('(?:_\\n|.)*)";
final String string = "ewr \"Having \"\"quoted\"\" quotes couldn't work, could they\"? \"Yeah, they do!\" 'Great\n"
+ "Working - This is a test 'This should be captured\n"
+ "Working - \"this is a test\" 'This should be captured\n"
+ "Not Working - \"this is a test\" 'This should be \"captured\"\n"
+ "Not Working - This is a test 'This should be \"captured\"\n"
+ "Working - \"this is a test 'this should not capture'\" 'this should capture\n"
+ "Working - \"this isn't a test\" 'this should capture\n"
+ "'Comment with a line _\n"
+ "continuation\n"
+ "Debug.Print 'End of line comment _\n"
+ "with line continuation.\n"
+ "Debug.Print 42 'The next line... _\n"
+ "\"...is not a string literal\"\n"
+ "Debug.Print \"Unmatched double quotes.\" 'Comment\"\n"
+ "Debug.Print \"Interleaved single 'n double quotes.\" 'Comment\"\n"
+ "'No comments or strings in the line below.\n"
+ "Debug.Print [Evil:\"\"Comment\"'here]\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}