// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)^(?:[^"'\n]*(?:"(?:[^"\n]|"")*"))*[^']*('(?:_\n|.)*)"#).unwrap();
let string = "ewr \"Having \"\"quoted\"\" quotes couldn't work, could they\"? \"Yeah, they do!\" 'Great
Working - This is a test 'This should be captured
Working - \"this is a test\" 'This should be captured
Not Working - \"this is a test\" 'This should be \"captured\"
Not Working - This is a test 'This should be \"captured\"
Working - \"this is a test 'this should not capture'\" 'this should capture
Working - \"this isn't a test\" 'this should capture
'Comment with a line _
continuation
Debug.Print 'End of line comment _
with line continuation.
Debug.Print 42 'The next line... _
\"...is not a string literal\"
Debug.Print \"Unmatched double quotes.\" 'Comment\"
Debug.Print \"Interleaved single 'n double quotes.\" 'Comment\"
'No comments or strings in the line below.
Debug.Print [Evil:\"\"Comment\"'here]
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}