import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\b\\d{4}\\b";
final String string = " '2025',\n"
+ " '2150 is the year to match',\n"
+ " 'the year is 2030 see ref 2099662',\n"
+ " 'Should match the year here YEAR_2140 even though it has non numric chars preceeding it',\n"
+ " 'Should match the year at the end of a string like this - 2140',\n"
+ " 'ref 2099662 the year is 2140. And there is another sentence',\n"
+ " 'ref 2099662 the end of the string is the year 2140',\n"
+ " 'There is no year here 2055667'";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}