$re = '/\b\d{4}\b/m';
$str = ' \'2025\',
\'2150 is the year to match\',
\'the year is 2030 see ref 2099662\',
\'Should match the year here YEAR_2140 even though it has non numric chars preceeding it\',
\'Should match the year at the end of a string like this - 2140\',
\'ref 2099662 the year is 2140. And there is another sentence\',
\'ref 2099662 the end of the string is the year 2140\',
\'There is no year here 2055667\'';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);