use strict;
my $str = ' \'2025\',
\'2150 is the year to match\',
\'the year is 2030 see ref 2099662\',
\'Should match the year here YEAR_2140 even though it has non numric chars preceeding it\',
\'Should match the year at the end of a string like this - 2140\',
\'ref 2099662 the year is 2140. And there is another sentence\',
\'ref 2099662 the end of the string is the year 2140\',
\'There is no year here 2055667\'';
my $regex = qr/\b\d{4}\b/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}