import Foundation
let pattern = #"\b\d{4}\b"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
'2025',
'2150 is the year to match',
'the year is 2030 see ref 2099662',
'Should match the year here YEAR_2140 even though it has non numric chars preceeding it',
'Should match the year at the end of a string like this - 2140',
'ref 2099662 the year is 2140. And there is another sentence',
'ref 2099662 the end of the string is the year 2140',
'There is no year here 2055667'
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)