const regex = /((?:https|http|ftp)?:\/\/)?([^\/,\s]+\.[^\/,\s]+?)(?=\/|,|\s|$|\?|#)(.*)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('((?:https|http|ftp)?:\\\/\\\/)?([^\\\/,\\s]+\\.[^\\\/,\\s]+?)(?=\\\/|,|\\s|$|\\?|#)(.*)', 'gm')
const str = `http://dominio.do/strig-dinâmica-000-0000-000
https://www.olympikus.com.br/tenis-olympikus-flower-415-feminino-cinza-D22-1131-010
ftp://dominio.br/strig-dinâmica-000-0000-000
dominio.c/strig-dinâmica-000-0000-000`;
const subst = `$3`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);