import Foundation
let pattern = ##"((?:https|http|ftp)?:\/\/)?([^\/,\s]+\.[^\/,\s]+?)(?=\/|,|\s|$|\?|#)(.*)"##
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
http://dominio.do/strig-dinâmica-000-0000-000
https://www.olympikus.com.br/tenis-olympikus-flower-415-feminino-cinza-D22-1131-010
ftp://dominio.br/strig-dinâmica-000-0000-000
dominio.c/strig-dinâmica-000-0000-000
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$3"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)