import re
regex = re.compile(r"((?:https|http|ftp)?:\/\/)?([^\/,\s]+\.[^\/,\s]+?)(?=\/|,|\s|$|\?|#)(.*)", flags=re.MULTILINE)
test_str = ("http://dominio.do/strig-dinâmica-000-0000-000\n"
"https://www.olympikus.com.br/tenis-olympikus-flower-415-feminino-cinza-D22-1131-010\n"
"ftp://dominio.br/strig-dinâmica-000-0000-000\n"
"dominio.c/strig-dinâmica-000-0000-000")
subst = "$3"
result = regex.sub(subst, test_str)
if result:
print(result)