$re = '/((?:https|http|ftp)?:\/\/)?([^\/,\s]+\.[^\/,\s]+?)(?=\/|,|\s|$|\?|#)(.*)/m';
$str = 'http://dominio.do/strig-dinâmica-000-0000-000
https://www.olympikus.com.br/tenis-olympikus-flower-415-feminino-cinza-D22-1131-010
ftp://dominio.br/strig-dinâmica-000-0000-000
dominio.c/strig-dinâmica-000-0000-000';
$subst = "$3";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;