using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(.*_.*){3,}|(\W)(.{,3}|.{20,})";
string input = @"uytfvhjg
fhhgd3fhhffghjhfffhjjgfxvhjhffghaj";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}