$re = '/(.*_.*){3,}|(\W)(.{,3}|.{20,})/m';
$str = 'uytfvhjg
fhhgd3fhhffghjhfffhjjgfxvhjhffghaj';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);