re = /(.*_.*){3,}|(\W)(.{,3}|.{20,})/m
str = 'uytfvhjg
fhhgd3fhhffghjhfffhjjgfxvhjhffghaj'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end