package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(.*_.*){3,}|(\W)(.{,3}|.{20,})`)
var str = `uytfvhjg
fhhgd3fhhffghjhfffhjjgfxvhjhffghaj`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}