#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?!.*\.)mcq_q[0-9]+"
Local $sString = ""mcq_q9"" & @CRLF & _
""mcq_q10"" & @CRLF & _
""mcq_q11"" & @CRLF & _
""mcq_q12"" & @CRLF & _
""mcq_q1.factor"" & @CRLF & _
""mcq_q2.factor"" & @CRLF & _
""mcq_q10.factor"" & @CRLF & _
""mcq_q11.factor"" & @CRLF & _
""mcq_q12.factor""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")