const regex = /(?!.*\.)mcq_q[0-9]+/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?!.*\\.)mcq_q[0-9]+', 'g')
const str = `"mcq_q9"
"mcq_q10"
"mcq_q11"
"mcq_q12"
"mcq_q1.factor"
"mcq_q2.factor"
"mcq_q10.factor"
"mcq_q11.factor"
"mcq_q12.factor"`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}