import Foundation
let pattern = #"(?!.*\.)mcq_q[0-9]+"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
"mcq_q9"
"mcq_q10"
"mcq_q11"
"mcq_q12"
"mcq_q1.factor"
"mcq_q2.factor"
"mcq_q10.factor"
"mcq_q11.factor"
"mcq_q12.factor"
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)