$re = '/(?!.*\.)mcq_q[0-9]+/';
$str = '"mcq_q9"
"mcq_q10"
"mcq_q11"
"mcq_q12"
"mcq_q1.factor"
"mcq_q2.factor"
"mcq_q10.factor"
"mcq_q11.factor"
"mcq_q12.factor"';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);