package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^([^\W_]+)_((?:[^\W_]+_)*)[^\W_]+$`)
var str = `asc_epsWarn_mu8
asc_ger_phiK_mi16
ARSrt_FAC_RED5_DSR_AU16`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}