re = /^([^\W_]+)_((?:[^\W_]+_)*)[^\W_]+$/m
str = 'asc_epsWarn_mu8
asc_ger_phiK_mi16
ARSrt_FAC_RED5_DSR_AU16'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end