import re
regex = re.compile(r"^([^\W_]+)_((?:[^\W_]+_)*)[^\W_]+$", flags=re.MULTILINE)
test_str = ("asc_epsWarn_mu8\n"
"asc_ger_phiK_mi16\n"
"ARSrt_FAC_RED5_DSR_AU16")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")