import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^([^\\W_]+)_((?:[^\\W_]+_)*)[^\\W_]+$";
final String string = "asc_epsWarn_mu8\n"
+ "asc_ger_phiK_mi16\n"
+ "ARSrt_FAC_RED5_DSR_AU16";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}