use strict;
my $str = 'DNA160630JA_JQ1_BRD4_A_S4_L001_R1_001.fastq
DNA160630JA_JQ1_BRD4_B_S8_L002_R1_001.fastq
DNA160630JA_JQ1_input_A_S3_L001_R1_001.fastq
DNA160630JA_JQ1_input_B_S7_L002_R1_001.fastq
DNA160630JA_mock_BRD4_A_S2_L001_R1_001.fastq
DNA160630JA_mock_BRD4_B_S6_L002_R1_001.fastq
DNA160630JA_mock_input_A_S1_L001_R1_001.fastq
DNA160630JA_mock_input_B_S5_L002_R1_001.fastq';
my $regex = qr/((?:JQ1|mock)_(?:BRD4|input)_(?:A|B))/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}