re = /((?:JQ1|mock)_(?:BRD4|input)_(?:A|B))/
str = 'DNA160630JA_JQ1_BRD4_A_S4_L001_R1_001.fastq
DNA160630JA_JQ1_BRD4_B_S8_L002_R1_001.fastq
DNA160630JA_JQ1_input_A_S3_L001_R1_001.fastq
DNA160630JA_JQ1_input_B_S7_L002_R1_001.fastq
DNA160630JA_mock_BRD4_A_S2_L001_R1_001.fastq
DNA160630JA_mock_BRD4_B_S6_L002_R1_001.fastq
DNA160630JA_mock_input_A_S1_L001_R1_001.fastq
DNA160630JA_mock_input_B_S5_L002_R1_001.fastq'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end