using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"([^\s])(#)";
string substitution = @"$1 $2";
string input = @" #слово# слово #слово слово#слово#слово#
#слово #слово#слово#слово";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}