$re = '/([^\s])(#)/m';
$str = ' #слово# слово #слово слово#слово#слово#
#слово #слово#слово#слово';
$subst = "$1 $2";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;