package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)([^\s])(#)`)
var str = ` #слово# слово #слово слово#слово#слово#
#слово #слово#слово#слово`
var substitution = "$1 $2"
fmt.Println(re.ReplaceAllString(str, substitution))
}