use strict;
my $str = ' #слово# слово #слово слово#слово#слово#
#слово #слово#слово#слово';
my $regex = qr/([^\s])(#)/mp;
my $subst = '$1 $2';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";