$re = '/(http|https|wss|ws|ftp|ftps):\/\//m';
$str = 'http://
https://
wss://
ws://
ftp://
ftps://';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);