package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(?<my_field>[^\&\?]*)`)
var str = `/temp/test?csrkyyt=12334
/test1/test2&csrkyyt=7968676`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}