// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(?<my_field>[^\&\?]*)").unwrap();
let string = "/temp/test?csrkyyt=12334
/test1/test2&csrkyyt=7968676";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}