re = /^(?<my_field>[^\&\?]*)/m
str = '/temp/test?csrkyyt=12334
/test1/test2&csrkyyt=7968676'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end