$re = '/^(?<my_field>[^\&\?]*)/m';
$str = '/temp/test?csrkyyt=12334
/test1/test2&csrkyyt=7968676';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);