using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[\r\n]{3,}";
string input = @"asdfsadf
asdfasdf
asdf
a
asdfasdf
asdfasdfasdf
asdfasdfa
asdf
asdfasdf
asdfsadfsd";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}