import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "[\\r\\n]{3,}";
final String string = "asdfsadf\n"
+ "asdfasdf\n"
+ "asdf\n"
+ "a\n"
+ "asdfasdf\n\n\n"
+ "asdfasdfasdf\n\n\n\n"
+ "asdfasdfa\n\n"
+ "asdf\n\n\n"
+ "asdfasdf\n\n\n\n"
+ "asdfsadfsd";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}