re = /[\r\n]{3,}/
str = 'asdfsadf
asdfasdf
asdf
a
asdfasdf
asdfasdfasdf
asdfasdfa
asdf
asdfasdf
asdfsadfsd'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end