$re = '/[\r\n]{3,}/';
$str = 'asdfsadf
asdfasdf
asdf
a
asdfasdf
asdfasdfasdf
asdfasdfa
asdf
asdfasdf
asdfsadfsd';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);