import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?!.*\\bdetails\\.cfm\\b).*\\bselector=size\\b.*$";
final String string = "http://www.anydotcom.com/test/search.cfm?metric=blah&abcselector=size&value=1\n"
+ "http://www.anydotcom.com/test/search.cfm?metric=blah2&selector=style&value=1\n"
+ "http://www.anydotcom.com/test/search.cfm?metric=blah3&selector=sizeabc&value=1\n"
+ "http://www.anydotcom.com/test/details.cfm?metric=blah&selector=size&value=1\n"
+ "http://www.anydotcom.com/test/search.cfm?metric=blah3&selector=size&value=1\n"
+ "http://www.anydotcom.com/test/search.cfm?metric=blah&selector=size&value=1\n"
+ "http://www.anydotcom.com/test/search.cfm?metric=blah3&value=1&selector=size\n"
+ "http://www.anydotcom.com/test/search.cfm?metric=blah&value=1&selector=size\n"
+ "http://www.anydotcom.com/test/details.cfmabc?metric=blah&selector=size&value=1\n"
+ "http://www.anydotcom.com/test/abcdetails.cfm?metric=blah&selector=size&value=1";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}