import Foundation
let pattern = #"^(?!.*\bdetails\.cfm\b).*\bselector=size\b.*$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
http://www.anydotcom.com/test/search.cfm?metric=blah&abcselector=size&value=1
http://www.anydotcom.com/test/search.cfm?metric=blah2&selector=style&value=1
http://www.anydotcom.com/test/search.cfm?metric=blah3&selector=sizeabc&value=1
http://www.anydotcom.com/test/details.cfm?metric=blah&selector=size&value=1
http://www.anydotcom.com/test/search.cfm?metric=blah3&selector=size&value=1
http://www.anydotcom.com/test/search.cfm?metric=blah&selector=size&value=1
http://www.anydotcom.com/test/search.cfm?metric=blah3&value=1&selector=size
http://www.anydotcom.com/test/search.cfm?metric=blah&value=1&selector=size
http://www.anydotcom.com/test/details.cfmabc?metric=blah&selector=size&value=1
http://www.anydotcom.com/test/abcdetails.cfm?metric=blah&selector=size&value=1
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)